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Overview of the NautilusCD Disc Index
The NautilusCD Disc Index is a standalone Windows application published with each issue 
of NautilusCD.    It is designed to provide expanded access to the content on each CD ROM.  
This is accomplished by providing a searchable listing of all the files and directories on each
disc.    In addition, the index contains a text description for many of the files on the disc.

The index is cumulative, allowing you to search for specific files on the current or previous 
editions of NautilusCD, copy files from NautilusCD discs to a hard drive, run applications 
and other files from the discs, and print information about files.

In addition to its standalone capabilities, the disc index also functions from within the 
NautilusCD magazine whenever you click on a "folder" icon to access specific material on 
the disc.



How To Navigate in the NautilusCD Index Window
In the upper left of the NautilusCD Index window you'll find a Directory Listing that allows 
you to navigate the index manually and shows you the hierarchical path to all available 
data.    The highlighted item in the Directory Listing is the current directory.    The files 
contained in that directory are displayed and can be browsed in the field below the 
Directory Listing.

Clicking on a directory will display the files and subdirectories it contains in the file list in 
the lower left window. Double-clicking on a directory will expand it, showing any 
subdirectories it contains.    Double-clicking an expanded directory entry will collapse it.    
You can also use the items contained in the Tree menu.

In addition to the menus, there are five index functions accessible from the row of buttons 
located on the upper right of the window including Search, Open, Copy, Print and Help.

On the right side of the window information about the selected file is displayed, including 
file name, path, type, and size; and a scrolling field for a text description of the item that 
can be much more informative than the 8 characters allowed in a DOS/Windows base 
filename.

At the bottom of the screen a status bar displays a dynamic description of any portion of 
index window you move the mouse over. 



Switching Indexes
Because NautilusCD includes indexes for past issues as well as the current month's, you 
can open the index file for a past issue, even if that issue's disc is not loaded in your CD 
ROM drive (although there must be a NautilusCD disc in the drive).

You can always tell which issue's index you are currently in by:

The directory listing window's second item from the top.
The checked menu entry under the Index menu.

To switch to a different index, you can double-click the "Indexes" entry at the top of the 
directory list window.    This will replace the directory tree with a list of all the available 
indexes on the disc currently in your CD ROM drive.    Double-clicking one of these will open 
that index.

Alternatively, you can simply choose the index you want to open from the Index menu.

Note:    Although you can browse and print the information from a past issue's index 
without loading that disc into your CD ROM drive, attempting to Run or Copy files from a 
past issue's index will display a dialog box asking you to load that disc into your drive.    In 
other words, each issue's index contains information about the files on a number of issues, 
but the files themselves are only on that issue's disc.

Anytime the Disc Index displays a dialog box asking you to insert a NautilusCD disc into 
your CD ROM drive, you can eject the current disc by clicking the Eject button (which is 
only visible if your system can eject discs, and only enabled if there is a disc currently in 
the drive.)    The Disc Index then waits for the proper disc to be loaded.    When you've done 
so, after the few seconds required for the spin-up time, the Disc Index will continue.    You 
can also cancel or exit by clicking the Cancel or Exit button in this dialog box.



    Search Disc Indexes
The NautilusCD Disc Index allows you to search for files and/or directories on one or more 
monthly issues.

The Search dialog box can be displayed by clicking the Search button (the first of the five 
buttons in the upper right of the window), or by selecting Search... from the Index menu.

Select Index(es) to Search

Because the NautilusCD Index is cumulative, you can select the index or combination of 
indexes you wish to search.    This is done by clicking the Search: drop-down list in the 
upper left of the search dialog box.    The default is to search the current index.    Other 
options are to search all indexes or to pick specific indexes from a list of all the indexes on 
the disc currently loaded in your CD ROM drive.
 
Entering Search Parameters

Once you have selected which index(es) to search, you can perform a search using any or 
all of four Search Parameters:

File Type
Filename
Where
Description 

Clicking on the File Type: drop-down list in the upper right of the Search dialog box will 
display a list of standard file types commonly found on NautilusCD Discs.    Selecting one of 
these file types will restrict your search to only those files, speeding up the search 
operation.    For example, the easiest way to find all the movie files on a disc is to select 
"Movie Files" from the File Type list and then click the Search button.

The Filename: field allows you to search for any specific file or files by name.    Wildcards 
are supported.
For example, a file named "find_me.txt" could be searched for by typing its name into this 
field and then clicking the Search button.    Typing "f*.txt" (without the quotes) into the 
Filename field would also find this file, as well as any other files whose names start with the
letter "f" and end with the ".txt" extension.

The Where: field allows you to restrict your search by where the file is located on the disc.  
To do this, enter a complete or partial path into this field.    For example, to find only files in 
the Education department, you could type "\EDUC" (without the quotes) into the "Where:" 
field.    Then you could select "Text Documents" from the "File Type:" drop-down list and 
click the Search button.    When the search is complete, all text documents in the "\EDUC" 
directory tree would be displayed in the Search Results window.

The Description: field allows you to search for files and/or directories that contain a 
specific word or phrase in their description, as seen in the Disc Index application when you 
click on a file.    Only part of a word needs to be entered in order to find that word, and so 
wildcards are not necessary in this field.    If you want only a whole word to be found, you 
can check the "Match Whole Word Only" option that appears when you have entered 
any text in the "Description:" field.    The search can be made case-sensitive by checking 



the "Case Sensitive Search" option, which also appears when any text is entered into the
"Description:" field.    For more information on these options, see Refining a Search.

When entering Search Parameters, you do not need to enter information in all the fields.    If
information is entered in more than one field, only files that match all the criteria will be 
found.    If a field is left blank, its criterion will not be considered in the search.

During a search, a window displays the volume currently being searched and the number of
matches found so far. You may cancel a search at any point by clicking the Cancel button 
on this window.    When the search is complete, the NautilusCD Index displays a list of all 
matching files and directories in a Search Results list in the File List window. 

You may then view information, Open or Copy the files in the Search Results window.    
Pressing the "Return" button above the Search Results window will close it and return to 
the directory and file that were selected before the search began.    The "GoTo" button will 
close the Search Results window and take you to the volume, path and file of the selected 
item in the Search Results window.



Refining a Search
While it's easy to conduct simple searches based only on File Type or Filename, they often 
produce extensive results, sometimes hundreds of files and directories, many of which may
not be what you are looking for.

Rather than browse dozens or even hundreds of items in an overly long Search Results list, 
you can refine your search parameters to focus more closely on those items that contain 
only the specific information you want.    To make your search easier, the NautilusCD Disc 
Index uses Wildcard characters in file names.

Using Wildcards in File Names

A wildcard is a special character used to represent one or more characters in a file name.    
The NautilusCD Index uses three wildcards:

Asterisk (*)

The asterisk stands for one or more characters when searching a file name.    For example, 
if you    knew there were Bach MIDI files, but couldn't remember their exact name or 
location, entering *Bach* would find any file with "Bach" as part of its name.

Question Mark (?)

The (?) stands for any one character in a file name.    For example, if you were searching for
a file but could not remember if the spelling was Alladin or Aladdin, the following term 
would apply:

Al??din

Number Sign (#)

The (#) works like the (?), but stands for any single digit in a file name.

One Caution...    

Though wildcards let you broaden a search to catch similar words, they can sometimes 
make your search too broad by matching literally thousands of terms!    So, at times you 
may need to revise your search term to make it more specific, and then perform the search
again.

Searching by Description

Searching by Description functions much like the text search capability of a word processor 
or text editor:    Searching by a word in the Description text field will find every occurrence 
of that word or word fragment    in the volume(s) you've selected for your search.

For example, entering "car" in the Description field will find car, cart, cardboard, carbuncle, 
carbine, Encarta, cartel, Carolina, etc.

To make your search more specific you can check the Case Sensitive Search or Match 
Whole Word Only boxes.    Thus, searching on "car" with Match Whole Word Only selected 
would only return "car," not any word that contains "car".



In general, using the "File Type:" parameter will produce the fastest searches.    For 
example, searching for all bitmap files on a certain disc could be done by typing "*.bmp" 
(without the quotes) into the "Filename:" field, or by selecting "Windows Bitmaps" from the 
"File Type:" field.    The method that uses "File Type:" will produce a faster search.



 Copy Files from NautilusCD Discs
You can use the NautilusCD Index to select multiple files and/or directories and copy them 
to your hard drive.

To Copy, first select the files to copy by holding down the Ctrl or Shift keys and clicking file
names: 
 

Ctrl-click selects or deselects files one at a time.

Shift-click selects or deselects ranges of files.

Or simply drag the mouse over the filenames while holding down the left mouse 
button.

Once you've selected the files you wish to copy,    click the Copy button or choose Copy... 
from the File menu.    A dialog box will appear that shows you the files and/or directories 
you have selected, the number of files selected (including any in selected directories), and 
the total size in bytes of all selected files (including any in selected directories).    You can 
then either type in the desired output directory, or click the "Browse" button to pick the 
output directory from a list of all directories on your system.    If you use the Browse 
method, the dialog box displays the available space on the target drive, so you can see if 
there is enough room for all the files you've selected to copy.    You will be notified if there is
not enough room, and the copy will not be performed.



 Open Files and Run Applications from the NautilusCD Disc Index
There are two ways of opening files or running applications from the Disc Index.    You can 
open/run the file directly, by double-clicking its name or choosing Open from the File 
menu; or you can open/run the file with additional command-line parameters by selecting 
the file and clicking the Open/Run button or choosing Run... from the File menu.    This 
method also allows you to specify whether the application should be run normally, 
minimized, or maximized.

If there are two files selected when the Open/Run button is pressed (or Run... is chosen 
from the File menu), and one of them is an executable file, then they are arranged into a 
command line automatically.

Clicking the OK button will run the command line exactly as it was entered.

When opening non-executable files, the Disc Index relies on the associations you have set 
up in Windows.    If you get an error message stating that there is no association for a file 
you have tried to open, you can set one up without leaving the Disc Index if desired.

Another option that relates to opening files or running applications is the Minimize On 
Use menu item under the Options menu.    Selecting this option will cause the Disc Index 
to be minimized just before it opens or runs any file or application.



Associations
When attempting to open a non-executable file, the Disc Index relies on the associations 
you have set up in Windows.    Associations are a way of telling the operating system how to
handle non-executable files.    Associations are based on file type, as determined by its 
extension (the last 3 characters of the filename, after the period).

Many of the files commonly found on NautilusCD discs already have default associations 
which were set up automatically when Windows was installed on your system.    For 
example, the default association for files with the extension .WRI is Windows Write.    As 
long as this association has not been changed, opening a file with this extension will cause 
Windows Write to execute and then load the file you selected.

Other file types are not given a default association when Windows is set up.    These file 
types can be associated by application setup programs (eg., the Video for Windows Setup 
supplies associations for .AVI movie files), by the user, or have no association at all.

If you attempt to open a non-executable file from the Disc Index, and receive an error 
message saying "There is no association for the selected file", then you have two options.    
One would be to use the Open/Run button or select Run... from the File menu.    This 
allows you to type in the name of the program you would like to use to open the selected 
file.    The other option is to select Associate... from the File menu and set up an 
association for files with that extension.

Let's use a file called 'read.me' as an example.    Files with this name are often supplied with
application programs, both commercial and shareware.    You would expect a file with this 
name to be a text file.    To open this file from the Disc Index, you could select it, click the 
Open/Run button (or select Run... from the File menu), press the Home key to move to 
the beginning of the command line, and then type "notepad " (or the name of a text 
viewer/editor of your choice).    The command line would then look like this:

notepad read.me

Clicking the OK button would then start Notepad and load the 'read.me' file.

This option works fine for the occasional file with an unusual extension.    However, if you 
find yourself doing this over and over for the same extensions, it makes sense to set up an 
association for them.    To do this from the Disc Index, first select the 'read.me' file by 
clicking on it, and then select Associate... from the File menu.    This displays a dialog box 
that allows you to choose which executable file to use as the association for any file ending 
with the ".me" extension.    If you choose Notepad (located by default in the directory where
Windows is kept on your system), then from that point on Notepad will be used to open files
with this extension.

Associations can be changed simply by re-associating a file's extension with a different 
executable file.

Note:    If you know the executable file you wish to use is in your system's Path (like 
Notepad), then you can simply type in its name in the "File Name:" field instead of 
navigating through your directory structure to find the file.



 Print Index Information
The Disc Index can print information about files.    To display the Print dialog box, click the 
Print button or choose Print... from the Index menu.

You can print:

The contents of the File List or Search Results window (with additional information)
The contents of the Description field attached to the selected file
Both.

The Disc Index prints to your system's default printer, as set up in your Control Panel.



 Keyboard Controls
Pressing the Tab key will move the focus, in the following order:

File List or Search Results Windows
Search Button
Open Button
Copy Button
Print Button
Help Button
Directory Listing Window

Shift-Tab will move the focus in the reverse order.

Directory Listing Keyboard Shortcuts

In addition to clicking the scroll bar, the arrow keys, Page Up, Page Down, Home, and 
End keys can also be used for moving around in the Directory window.

The + and - keys will expand or collapse the selected directory, respectively.
The * key will expand the selected branch, and Ctrl- * will expand the entire directory tree.

(Note: many keyboards have gray +, -, and * keys located on the numeric keypad.    Using 
these keys will avoid having to use the shift key to access the normal + and * keys.)

Pressing the Enter key is equivalent to double-clicking the selected directory.

Pressing a letter key or number key will cause the next item starting with that character 
to be highlighted.

File or Search Results Listing Keyboard Shortcuts

In addition to clicking the scroll bar, the arrow keys, Page Up, Page Down, Home, and 
End keys can also be used for moving around in the File or Search Results window.

Pressing the Enter key is equivalent to double-clicking the selected file.

Pressing a letter key or number key will cause the next item starting with that character 
to be highlighted.

You can select multiple files by:
Holding down the Shift key while clicking with the mouse (selects a range of files)
Holding down the Ctrl key while clicking with the mouse (selects or deselects 
individual files)
Dragging the mouse over files while holding the mouse button down
Choosing Select All from the File menu or Pressing Ctrl-/ (selects all files)
Choosing Select Files... from the File menu (allows wildcard selection - eg. "*.exe")

Index Function Shortcuts

When one of the command buttons has the focus, pressing the Enter key or the spacebar 
has the same effect as clicking the button.    In addition the corresponding menu commands



for each button can be accessed by pressing the underlined letter in the menu text while 
holding down the Alt key.

Description field

Although there is no button or menu command for copying selected description text to the 
clipboard, it can be done by selecting the text and pressing Ctrl-C.



How to Quit the NautilusCD Index
There are four ways to quit the index:

Select Exit from the File menu
Double-click the Control Box (upper left of the screen)
Select Close from the Control Menu
Press Alt-F4.



NautilusCD Technical Support
Need Assistance?

If you have questions regarding the NautilusCD Index or any other feature or function of 
NautilusCD, contact our Technical Support representatives weekdays between the hours of 
8:30 a.m. and 5:30 p.m. [Eastern]:

Voice: 614/766-3150

Fax: 614/761-4110




